Nationwide Outage With Verizon Wireless
Incident Report for ProxyGuys
Resolved
As of now, all cell sites are fully online and operational again.
Posted Jul 22, 2020 - 19:00 PDT
Update
Most of our cell sites are back online except Los Angelas & Seattle. We continue to wait for updates from Verizon Wireless however at the rate of cell sites returning to normal we anticipate that the final two sites should be back online shortly.
Posted Jul 22, 2020 - 17:45 PDT
Update
Unfortunately, we continue to wait for further updates from Verizon Wireless.
Posted Jul 22, 2020 - 16:00 PDT
Update
Some of our physical cell sites are still offline. We will continue to post all updates here as soon as they become available.
Posted Jul 22, 2020 - 14:30 PDT
Update
Some of our physical cell sites have returned online including Buffalo, NY - New York, NY - San Diego, CA - Phoenix, AZ - Houston, TX - Charlotte, NC - Atlanta, GA
Posted Jul 22, 2020 - 12:45 PDT
Update
Unfortunately, we continue to wait for updates from Verizon Wireless.
Posted Jul 22, 2020 - 12:00 PDT
Update
We are still awaiting further official updates from Verizon Wireless.
Posted Jul 22, 2020 - 10:00 PDT
Update
Unfortunately, we continue to wait for updates from Verizon Wireless.
Posted Jul 22, 2020 - 08:00 PDT
Update
We continue to monitor the situation but at this time we have no valuable updates to share with our users.
Posted Jul 22, 2020 - 05:00 PDT
Update
Still no updates from Verizon Wireless and no public announcements at this time. Verizon does not maintain a public "status" page that we are able to share with the public. Multiple users on Twitter & DownDetector reporting outages across the USA as the issue is widespread.
Posted Jul 22, 2020 - 04:00 PDT
Monitoring
Unfortunately, we have no updates from our Verizon support team at this time. We are on standby and constantly monitoring our systems ready to restart all services once the cell sites come online again.
Posted Jul 22, 2020 - 03:00 PDT
Identified
Verizon Wireless is experiencing a major service outage in multiple markets across the USA as of 1:30 am PST that is negatively affecting over 10 of our physical cellular sites. At this time the outage is out of our control as we wait for updates from the Verizon network engineering team.

The following locations appear to be down at the moment: Los Angeles, Detroit, Buffalo, Miami, Milwaukee, Dallas-Fort Worth, Seattle, Philadelphia, Denver, and Nashville.

The following locations are currently online and operating normally: Charlotte, Houston, Phoenix, San Diego & New York.
Posted Jul 22, 2020 - 02:00 PDT
Investigating
Our monitoring systems have detected major service outages with Verizon Wireless at the majority of our physical locations across the USA. We are currently on the phone with our Verizon reps seeking further information
Posted Jul 22, 2020 - 00:30 PDT
This incident affected: ProxyGuys Shared Servers (LosAngeles1 Shared Proxy, Miami1 Shared Proxy) and ProxyGuys Cellular Sites (Buffalo, New York, Los Angeles, California, Miami/Orlando, Florida, Milwaukee, Wisconsin, Dallas-Fort Worth, Texas, Seattle, Washington, Philadelphia, Pennsylvania, Denver, Colorado, Nashville, Tennessee, Detroit, Michigan).